Videos choppy or pause?


#1

I can really use your help, please!

  1. Open any video you’ve noticed this issue on.
  2. Press “D” on your keyboard to open a debug panel in the player.
  3. Press play and watch the video for a full minute (or until the video ends), while capturing the issue. Important: Do not let the video end before moving on to step #4 (otherwise, the debug panel will disappear!)
  4. Click the blue “Open link” button.
  5. Copy the link below the words “Share your results by copying this URL.”

Then, either send it through the contact form or reply to this thread and paste the url.

Also, is this happening on all videos, or just on certain ones?


#2

#3

Howdy Ben,

I wanted to give you a good (bad) example. The problem on this system (EDIT: to be clear, “This system” means my computer where I am watching the videos) is very old drivers. I don’t get these problems on my newer systems, but thought it might be helpful to see the debug info:

https://player.vimeo.com/debug/v2?key=1dd3768b070bc2e4d5646274eac06bee334ce98e1509587090_228996263_1&sessionId=1dd3768b070bc2e4d5646274eac06bee334ce98e1509587090&clipId=228996263&playing=1920×1080%4030%205%2C751%20Kbps&dimensions=1110×624%20&delivery=dash%2C%20cdn%3A%20akfire_interconnect_quic&ua=Mozilla%2F5.0%20(Windows%20NT%205.1)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F49.0.2623.112%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fwill-the-circle-be-unbroken-build-a-break-guitar-advanced&country=US&duration=61.589333&testGroup=manifest_retry%3A%20true&profileId=175%2C%201080p&droppedFrames=958&totalFrames=1332&droppedFramesPercent=71.92%&liveLatency=61.59%20seconds&bandwidthNow=9%2C483%20Kbps&bandwidthMin=5%2C631%20Kbps&bandwidthMax=11%2C084%20Kbps&startTime=Wed%20Nov%2001%202017%2020%3A44%3A50%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2020%3A50%3A38%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null


#4

I JUST sat down to watch your new “Are You Washed In the Blood” video and had this exact problem. Thing is, I’ve never seen it happen before, and I’m almost certain I’ve watched that video several times on this PC. Anyway, here’s the link you asked for.

https://player.vimeo.com/debug/v2?key=447f683a9cf3eaa47755c5477103ecdce4a22b261509587467_238597318_0&sessionId=447f683a9cf3eaa47755c5477103ecdce4a22b261509587467&clipId=238597318&playing=1920×1080%4030%205%2C375%20Kbps&dimensions=1110×624%20&delivery=dash%2C%20cdn%3A%20fastly_skyfire&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20Win64%3B%20x64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fare-you-washed-in-the-blood-fingerstyle-guitar-advanced&country=US&duration=99.029333&testGroup=manifest_retry%3A%20true&profileId=175%2C%201080p&droppedFrames=619&totalFrames=2861&droppedFramesPercent=21.64%&liveLatency=3.15%20seconds&bandwidthNow=55%2C841%20Kbps&bandwidthMin=47%2C382%20Kbps&bandwidthMax=61%2C112%20Kbps&startTime=Wed%20Nov%2001%202017%2020%3A51%3A07%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2020%3A53%3A26%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null


#5

Just watched Life’s Railway to Heaven. The problem wasn’t nearly as bad, but I noticed that the video resolution isn’t as high as the previous video. Maybe Vimeo is having trouble streaming full 1080p? Anyway, here’s the link for that video.

https://player.vimeo.com/debug/v2?key=dae00faf9464027beaeeae0582da57f60571e37d1509587732_201206110_0&sessionId=dae00faf9464027beaeeae0582da57f60571e37d1509587732&clipId=201206110&playing=1280×720%4030%203%2C098%20Kbps&dimensions=1110×624%20&delivery=dash%2C%20cdn%3A%20fastly_skyfire&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20Win64%3B%20x64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Flifes-railway-to-heaven-guitar&country=US&duration=56.277333&testGroup=manifest_retry%3A%20false&profileId=174%2C%20720p&droppedFrames=87&totalFrames=1517&droppedFramesPercent=5.74%&liveLatency=4.56%20seconds&bandwidthNow=17%2C151%20Kbps&bandwidthMin=17%2C151%20Kbps&bandwidthMax=52%2C274%20Kbps&startTime=Wed%20Nov%2001%202017%2020%3A55%3A32%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2020%3A56%3A25%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null


#6

For a 3rd test, I went down to Big Sciota, which seems to have a video resolution even smaller than the previous 2, though it didn’t list the resolution like the others. Absolutely no choppiness at all. Here’s the link for that.

https://player.vimeo.com/debug/v2?key=1c7bdb936c026860dd370d68861f018ccd18ea6d1509587906_109088044_0&sessionId=1c7bdb936c026860dd370d68861f018ccd18ea6d1509587906&clipId=109088044&playing=null&dimensions=1110×624%20&delivery=progressive%2C%20cdn%3A%20level3&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20Win64%3B%20x64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fbig-sciota-guitar&country=US&duration=59.925333&testGroup=manifest_retry%3A%20true&profileId=null&droppedFrames=0&totalFrames=0&droppedFramesPercent=0&liveLatency=3.67%20seconds&bandwidthNow=0&bandwidthMin=0%20Kbps&bandwidthMax=0%20Kbps&startTime=Wed%20Nov%2001%202017%2020%3A58%3A26%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2020%3A59%3A19%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null

After seeing this one work perfectly, I went back to Are You Washed in the Blood. Within 5 seconds, it was already glitching on me. So, it sure seems to be a resolution / bandwidth issue.


#7

Haha Mark… you can’t touch my 71.92% frame drop percentage :grinning:

On a relatively modern system with drivers from this century, I re-ran the same test as above. It worked ALMOST flawlessly. There was one brief buffering pause. Notably, it did not drop a frame. It paused briefly and then finished without any hiccups. Both of these tests were run on the same ISP with about 50GB download speed.

One thing I can say: the user end equipment and drivers make a huge difference.

https://player.vimeo.com/debug/v2?key=3e04d26c0080e2699696fa7b876974c1715fbc5f1509588120_228996263_0&sessionId=3e04d26c0080e2699696fa7b876974c1715fbc5f1509588120&clipId=228996263&playing=1920×1080%4030%205%2C751%20Kbps&dimensions=1110×624%20&delivery=dash%2C%20cdn%3A%20akfire_interconnect_quic&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20Win64%3B%20x64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fwill-the-circle-be-unbroken-build-a-break-guitar-advanced&country=US&duration=61.589333&testGroup=manifest_retry%3A%20false&profileId=175%2C%201080p&droppedFrames=0&totalFrames=1845&droppedFramesPercent=0.00%&liveLatency=61.59%20seconds&bandwidthNow=8%2C101%20Kbps&bandwidthMin=4%2C511%20Kbps&bandwidthMax=11%2C060%20Kbps&startTime=Wed%20Nov%2001%202017%2021%3A02%3A00%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2021%3A03%3A24%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null


#8

Mark,
Based on your comments I went back to try “Are you washed…” It ran flawlessly for me at 1080p (the default). So, at least when I was trying it, the server had plenty of bandwidth to serve that level of resolution.

https://player.vimeo.com/debug/v2?key=ba685da5ecb8254f90e9c008d50ddf9253ebc91b1509588922_238597318_0&sessionId=ba685da5ecb8254f90e9c008d50ddf9253ebc91b1509588922&clipId=238597318&playing=1920×1080%4030%205%2C375%20Kbps&dimensions=1110×624%20&delivery=dash%2C%20cdn%3A%20fastly_skyfire&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20Win64%3B%20x64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fare-you-washed-in-the-blood-fingerstyle-guitar-advanced&country=US&duration=99.029333&testGroup=manifest_retry%3A%20false&profileId=175%2C%201080p&droppedFrames=0&totalFrames=2555&droppedFramesPercent=0.00%&liveLatency=13.87%20seconds&bandwidthNow=34%2C374%20Kbps&bandwidthMin=24%2C180%20Kbps&bandwidthMax=38%2C838%20Kbps&startTime=Wed%20Nov%2001%202017%2021%3A15%3A22%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Wed%20Nov%2001%202017%2021%3A17%3A00%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=null


#9

You may be on to something. My system is an older box. Tonight is the first time I’ve ever had a problem though. Not sure what to make of it.


#10

Hi Ben,

What I have noticed is some of the video’s from the old site where you have edited out the humorous intro’s tend to stall in the first few minutes. It’s not a big issue to restart so I never considered it a problem. But I do miss those chuckle moment’s. The new website just isn’t the same without them.


#11

I know, and there will be more to come. But folks want content and they want to see what they’re going to learn ASAP. thanks.


#12

I’ve always felt the humour and the learning content a good working balance. Other teaching methods I’ve used lack the kind of personal interaction you have with your students. After a while their lessons become boring. Seriously Ben you should check some of them out. Your humour puts students at ease, you prepare the ground for the serious content that follows. That’s my humble opinion.


#13

I noticed that the instrument demos ran flawlessly on my old coal-fired PC. I tried the first Salt Creek mando video and got an unusable video with a frame drop in excess of 70%. I dropped the resolution to 360P and got a totally usable video that gave the following debug info:
https://player.vimeo.com/debug/v2?key=35118812d3480a597050450b76c491e6c74d0f7d1509739143_240093335_0&sessionId=35118812d3480a597050450b76c491e6c74d0f7d1509739143&clipId=240093335&playing=640×360%4030%20640%20Kbps&dimensions=300×150%20&delivery=dash%2C%20cdn%3A%20akfire_interconnect_quic&ua=Mozilla%2F5.0%20(Windows%20NT%205.1)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F49.0.2623.112%20Safari%2F537.36&referrer=https%3A%2F%2Fbanjobenclark.com%2Flessons%2Fsalt-creek-basic-intermediate-mandolin-beginner&country=US&duration=85.119999&testGroup=manifest_retry%3A%20true&profileId=164%2C%20360p&droppedFrames=371&totalFrames=2437&droppedFramesPercent=15.22%&liveLatency=15.40%20seconds&bandwidthNow=7%2C573%20Kbps&bandwidthMin=1%2C494%20Kbps&bandwidthMax=11%2C314%20Kbps&startTime=Fri%20Nov%2003%202017%2014%3A59%3A03%20GMT-0500%20(Central%20Daylight%20Time)&debugTime=Fri%20Nov%2003%202017%2015%3A01%3A41%20GMT-0500%20(Central%20Daylight%20Time)&sentryId=0d974ca7f3454ebbb39491bec33f6487

If someone is having trouble watching a vid, I’d suggest to try switching to a lower resolution. If that allows folks to get moving forward, then that is pretty good in itself. However, that actually still leaves a conversion at the viewing end, because the frame size is already set. The instrument demos look awesome (albeit small) because they are showing in their native format. Perhaps a Cadillac solution would be to offer both high and low resolution videos for primary content. The low res might be helpful for folks that have slow/older systems and some mobile devices (what benefit is 1080P on a 4 inch screen?)


#14

The vids are hosted on Vimeo and Vimeo is supposed to recognize your capabilities and auto-serve you the best resolution.


#15

https://player.vimeo.com/debug/v2?key=fc5ad62ad61f4d2c105336cc214cf25f08f5b19b1515933941_250804313_0&sessionId=fc5ad62ad61f4d2c105336cc214cf25f08f5b19b1515933941&clipId=25

Ben, husband growing very frustrated, unable to play any of the lessons he has pulled up. Viewing on IPad, has been away from lessons for a while and just getting into your new website. Can’t seem to play anything of yours… able to watch Netflix, view videos on YouTube etc… need some help!!


#16

Please send me an email through the contact form on the help page, please. When you do, I need more details besides they’re unable to play. What exactly is happening? Also, please do the following things before sending me the email:

  • Restart your iPad.
  • Check for any updates on your iPad.
  • Make sure private browsing is not turned on in your settings.
  • Download Google Chrome on your iPad and test videos through that browser.

Thanks for your help and your patience! I look forward to getting this fixed. I have lots and lots of folks on iPads on the site (including myself) without issue, so there’s something on your end that we need to find.


#17

Also which iPad is it? My old iPad mini can’t be upgraded to iOS version 10 or later, so I’m stuck at version 9, which is quickly losing functionality on the internet.


#18

“Are You Washed In the Blood” Video works fine for me. But not when I click on the code on this page.


#19

Just realised this is old issues that have since been resolved.